CIS 221 Lab 9 Supporting Applications in Windows XP Professional


Lab 9 Supporting Applications in Windows XP Professional
This lab contains the following exercises and activities:

· Exercise 9-1: Using Group Policy to Distribute Software

· Exercise 9-2: Assessing Product Compatibility

· Lab Review Questions

Scenario
Contoso, Ltd., has a large public clientele and has many call centers to help service customers. These call centers contain large numbers of employees and computers.

To distribute software to these users and computers, you need to use Group Policy to assign or publish software as appropriate. Also, Contoso uses some applications that are old and require you to set compatibility settings.
After completing this lab, you will be able to:

· Create a software distribution point (SDP).

· Publish and assign software to users through Group Policy.

· Assign software to computers through Group Policy.

· Check system information for product compatibility.

Before You Begin
Establish your network connection using the following steps.

1. Log on as local Administrator.

2. From the Start menu right click on My Computer and select Properties

3. From the Computer Name tab click on Change.

4. In the Computer Name Change dialog box erase .local from the Domain box.

5. Click OK

6. In the Computer Name Chang dialog box in User name type Administrator and in the Password box type none.

7. Click OK

8. After a few seconds you will be welcomed to the Contoso domain click OK.

9. Click on the dialog box that tells you that you must restart your computer.

10. Click OK in the Systems Properties dialog box.

11. Click Yes in the Systems Setting Change dialog box, you computer will shut down and restart.

12. Log on as local administrator.

13. From the start menu select Control Panel
14. Select Security Center

15. Open the Windows Firewall and make sure that it is Off.

16. Close all windows.

There are no prerequisites for Lab 9 for the student. The instructor needs to run the ContosoCallCenter.vbs script to create the necessary Active Directory objects.

This lab uses the variable xx to refer to your number so that your computer name is referred to as Computerxx and your student identity as Studentxx. You are asked to pair with another student in this lab. Your partner's number is referred to as yy.

This lab uses Microsoft Internet Explorer. Internet Explorer might display message boxes with security issues that cannot be anticipated in the steps. When this occurs, select the Do Not Show This Message Again check box if applicable, and dismiss the message box
Exercise 9-1: Using Group Policy to Distribute Software

The call centers at Contoso need to have new software named Litware be avail-able to members of the Call Center xx organizational unit (OU) in the Add Or Remove Programs utility. Before you can publish software to this OU, however, you need to create a console that will assist you, and you need to create a software distribution point (SDP) that will store the Microsoft Installer (MSI) files used for deployment.

Creating a GPO Management Console

The following will create a custom Microsoft Management Console (MMC) for creating the SDP and editing the appropriate group policy object (GPO).

1. Log on with your Contoso student account. (The password is P@sswOrd.)

2. From the Start menu, select Run.

3. In the Run dialog box, in the Open text box, type runas▲/user:Contoso\ studentadmin▲mmc and then press ENTER.

4. At the Enter The Password For Contoso \ Studentadmin prompt, type P@sswOrd (there is no echo back of the typed password) and then press ENTER.

5. In the Console1 console, from the File menu, select Add/Remove Snap-In.

6. In the Add/Remove Snap-In dialog box, click Add.

7. In the Add Standalone Snap-ln dialog box, select Computer Management and then click Add.

8. In the Computer Management dialog box, ensure that Local Computer: (The Computer This Console Is Running On) is selected, and then click Finish.

9. In the Add Standalone Snap-In dialog box, select Group Policy Object Editor 
Question 1: What is the description for the Group Policy Object Editor? Lab9/Fig 01

10. Click Add.

11. In the Select Group Policy Object Wizard, on the Welcome page, click Browse.

12. In the Browse For A Group Policy Object dialog box, on the Domains/ OUs tab, double-click Call Centers.Contoso.Local.

13. Double-click Call Center xx.Call Centers.Contoso.Local.

14. Select Software Distribution, and then click OK.

15. In the Select Group Policy Object Wizard, click Finish.

16. In the Add Standalone Snap-In dialog box, click Close.

17. In the Add/Remove Snap-In dialog box, click OK.

18. From the File menu, select Save.

19. In the Save As dialog box, in the File Name text box, type C:\Group Policy Management and then click Save.

Tip:  We are saving the custom console on the root of drive C, which is convenient for this lab but would not be a good idea in a real-world environment. In a real-world networked environment, it is useful to deposit frequently used administrative tools, such as custom consoles, in a share with administrator-only access. You can then use the Runas command to access the tools from any computer on the network logged on with a domain user or local user account.

20. Leave the Group Policy Management console open for the next task.
Creating an SDP

The following steps will create an SDP.

1. In the console tree, expand Computer Management (Local), expand System Tools, Shared Folders, select Shares, and then from the Action menu select New File Share.

2. In the Create A Shared Folder Wizard, on the Welcome page, click Next.

3. On the Set Up A Shared Folder page, in the Folder To Share text box, type 
C:\Call Center yy SDP.

4. In the Share Name text box, type Call Center yy SDP and then click Next.

5. In the Create Shared Folder Wizard dialog box, click Yes to create the new directory.

6. In the Shared Folder Permissions page, select Administrators Have Full Control; Other Users Have Read-Only Access and then click Next.

7. On the Completing The Create A Shared Folder Wizard page, 
Question 2: What is the path to the folder you created and who is it shared with? Lab 9/Fig 02

8. Click Finish.

9. From the Start menu, select My Computer.

10. In the My Computer window, browse to C:\Lab Manual\Lab 9.
11. Select Litware2.0.msi and Litware2.5.msi (holding down the CTRL key and clicking both to select both). From the Edit menu, select Copy.

12. Browse to C:\Call Center yy SDP.

13. In the C:\Call Center yy SDP window, from the Edit menu, select Paste.

14. Close the C:\Call Center yy SDP window. Leave the Group Policy Management console open for the next task.

Publishing Software Using Group Policy

The following steps will edit the GPO attached to the Call Center xx OU to publish Litware to the users in the OU.

1. In the Group Policy Management console, in the console tree, expand Software Distribution [SERVER01.Contoso (Local) Policy, User Configuration, Software Settings, and then select Software Installation.
2. Remove any items found by 

a. Right-clicking on the item

b. Hover over All Tasks

c. Select Remove

d. Click OK
3. From the Action menu, point to New and then select Package.

Note: Wait until your partner has completed the previous step before continuing.

4. In the Open dialog box, click My Network on the left.

5. Double-click Entire Network, Microsoft Windows Network, Contoso, Computeryy, Call Center xx SDP and then double-click Litware2.0.

6. In the Deploy Software dialog box, ensure that Published is selected, and then click OK.

7. Log off.
Installing Published Software

The following steps will install the published Litware2.0 software.

Important: Wait until your partner has completed the previous task before continuing.

1. Log on to Contoso as SharonHxx. 

2. From the Start menu, select Control Panel.

3. In Control Panel, click Add Or Remove Programs.

4. In the Add Or Remove Programs window, click Add New Programs on the left.

5. In the Add Programs From Your Network list, next to Litware2.0, click Add. Installation will occur.

6. Close the Add Or Remove Programs dialog box and Control Panel.

7. From the Start menu, point to All Programs, and then select Litware2.0.
Question 3: What is the message that appears?

8. Click OK.

Assigning Software Using Group Policy

The Litware software has proved very valuable to the call center employees, but it contains some major bugs. A new release is out (version 2.5), which fixes many of these problems.

1. From the Start menu, select My Computer.

2. In the My Computer window, double-click Local Disk (C:). If necessary, click Show The Contents Of This Folder.

3. In the Local Disk (C:) window, right-click Group Policy Management and then select Runas.

4. In the Run As dialog box, select The Following User.

5. In the User Name text box, type Contoso\SuldentAdmin.

6. In the Password Text box, type P@sswOrd and then press ENTER.

7. In the Group Policy Management console, in the console tree, expand Software Distribution [SERVER.Contoso.Local] Policy, User Configuration, Software Settings, and then select Software Installation.

8. From the Action menu, point to New and then select Package.

9. In the Open dialog box, if you are not already in Call Center xx On Computer yy, browse there, and then double-click Litware2.5.

10. In the Deploy Software dialog box, select Assigned and then click OK.

11. In the Group Policy Management console, in the details pane, right-click Litware2.5 and then select Properties.

12. In the Litware2.5 Properties dialog box, on the Upgrades tab, select Required Upgrade For Existing Packages. Click Add.

13. In the Add Upgrade Package dialog box click OK.

14. In the Litware2.5 Properties dialog box, on the Deployment tab, select the Install This Application At Logon check box. Click OK.
15. From the File menu select Save.
16. Log off.
Installing Assigned Software

The following steps will cause the assigned software to be installed and will verify its installation.

Important: Wait until your partner has completed the previous task before continuing.

1. Log on to Contoso as SharonHxx.

2. From the Start menu, point to All Programs, and then select Litware2.5.

3. Read the Windows Script Host message box, and then click OK.

4. Log off.
Exercise 9-2: Assessing Product Compatibility

Product compatibility is a frequent problem at Contoso. The problem tends to occur in two varieties: 1) the computer and the operating system are too new and cannot run legacy applications correctly, or 2) the computer is too old and does not have sufficient resources to run an application.

To mitigate these problems, you need to be able to configure compatibility by using the Compatibility tab, and you need to be able to check system resources to see if they are adequate for the specific software requirements.

Checking System Requirements

In this section you will connect to your partners computer and determine the current hardware installed on their computer..

Checking System Information with Computer Management

The following steps will use the Computer Management tool to check system resources.

1. Log on to Contoso with your student account.

2. From the Start menu, select Run.

3. In the Run dialog box, in the Open text box, type 
runas▲/user:computerxx\administrator▲mmc and then press ENTER.

4. At the Enter The Password For Computerxx\Administrator prompt, type P@ssw0rd and then press ENTER.

5. In the Console1 console, from the File menu, select Add/Remove Snap-In.

6. In the Add/Remove Snap-In dialog box, click Add.

7. In the Add Standalone Snap-In dialog box, select Computer Management and then click Add.

8. In the Computer Management dialog box, select Another Computer, and in the text box, type Computeryy. Click Finish.

9. In the Add Standalone Snap-In dialog box, click Close.

10. In the Add/Remove Snap-In dialog box, click OK.

11. In the Console1 console, in the console tree, expand Computer Management (Computeryy) and System Tools, and then select Device Manager.

Question 4: Summarize the message in the dialog box that appears. Lab9/fig 03
12. In the Device Manager dialog box, click OK.
13. In the details pane, expand Display Adapters, Network Adapters, and Processors and fill in the following table.
Question 5: Fill in the following table

	Display Adaptor
	

	Network Adaptor
	

	Processor
	


14. In the console tree, expand Storage and then select Disk Management.

Question 6: Fill in the following table from the Details pane.

	Capacity C:
	

	Free Space C:
	

	% Free C:
	

	Capacity L:
	

	Free Space L:
	

	% Free L:
	


15. In the console tree, right-click Computer Management (Computeryy) and then select Properties.
16. In the Computer Management (COMPUTERyy) Properties dialog box, on the General tab, read the Computer section to determine how much RAM your partner's computer has. 
Question 7: How much RAM memory does your partners computer have?
17. Close the Console1 console, and do not save changes when asked. 
Lab Review Questions
1. What is the difference between assigning and publishing software to users through Group Policy?

2. What is the difference between assigning and publishing software to computers through Group Policy?
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